DOTCOMM | Investigating service disruption | Monitor is DOWN: DC Treas Tax Payments ( https://payments.dctreasurer.org ).
Incident Report for dotcomm
Resolved
The Web Sites issue is resolved.
Posted Dec 18, 2023 - 06:57 CST
Investigating
We’re currently experiencing a Web Sites service disruption.
Monitor is DOWN: DC Treas Tax Payments ( https://payments.dctreasurer.org ).
DOTCOMM is working to identify the root cause and working on remediation.
Posted Dec 18, 2023 - 06:53 CST
This incident affected: Web Services.