DOTCOMM | Investigating service disruption | Monitor is DOWN: City of Omaha Finance Website ( https://finance.cityofomaha.org/ ).
Incident Report for dotcomm
Resolved
The Web Sites issue is resolved.
Posted Oct 17, 2023 - 07:46 CDT
Investigating
We’re currently experiencing a Web Sites service disruption.
Monitor is DOWN: City of Omaha Finance Website ( https://finance.cityofomaha.org/ ).
DOTCOMM is working to identify the root cause and working on remediation.
Posted Oct 17, 2023 - 07:42 CDT
This incident affected: Web Services.